Port: Link with no-undefined on Windows
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index cb625e5c1bfa3ed31c24d12c83e172fc4361d282..df87bc3005311d6b297d3680d1d7fe06306d914c 100644 (file)
@@ -1,16 +1,35 @@
-AM_CPPFLAGS = -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
+                         -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
                          -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = lttng-relayd
 
-lttng_relayd_SOURCES = main.c lttng-relayd.h
+lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
+                       index.c index.h live.c live.h ctf-trace.c ctf-trace.h \
+                       cmd-generic.c cmd-generic.h \
+                       cmd-2-1.c cmd-2-1.h \
+                       cmd-2-2.c cmd-2-2.h \
+                       cmd-2-4.c cmd-2-4.h \
+                       health-relayd.c health-relayd.h \
+                       lttng-viewer-abi.h testpoint.h \
+                       viewer-stream.h viewer-stream.c \
+                       session.c session.h \
+                       stream.c stream.h \
+                       stream-fd.c stream-fd.h \
+                       connection.c connection.h \
+                       viewer-session.c viewer-session.h \
+                       tracefile-array.c tracefile-array.h
 
 # link on liblttngctl for check if relayd is already alive.
-lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
-               $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+lttng_relayd_LDADD = -lurcu-common -lurcu \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/compat/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/index/libindex.la \
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la \
+               $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
This page took 0.023094 seconds and 4 git commands to generate.