relayd: initialize the global fd tracker from fd_cap option
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index c7dd37e1ae5e356f7bcec2082665a4d1f21bacbb..4fc35dc0f1881e90d05a6912d86e2ace525d0cbb 100644 (file)
@@ -9,10 +9,10 @@ bin_PROGRAMS = lttng-relayd
 
 lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
                        index.c index.h live.c live.h ctf-trace.c ctf-trace.h \
-                       cmd-generic.c cmd-generic.h \
                        cmd-2-1.c cmd-2-1.h \
                        cmd-2-2.c cmd-2-2.h \
                        cmd-2-4.c cmd-2-4.h \
+                       cmd-2-11.c cmd-2-11.h \
                        health-relayd.c health-relayd.h \
                        lttng-viewer-abi.h testpoint.h \
                        viewer-stream.h viewer-stream.c \
@@ -21,7 +21,10 @@ lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
                        stream-fd.c stream-fd.h \
                        connection.c connection.h \
                        viewer-session.c viewer-session.h \
-                       tracefile-array.c tracefile-array.h
+                       tracefile-array.c tracefile-array.h \
+                       tcp_keep_alive.c tcp_keep_alive.h \
+                       sessiond-trace-chunks.c sessiond-trace-chunks.h \
+                       backward-compatibility-group-by.c backward-compatibility-group-by.h
 
 # link on liblttngctl for check if relayd is already alive.
 lttng_relayd_LDADD = -lurcu-common -lurcu \
@@ -33,4 +36,5 @@ lttng_relayd_LDADD = -lurcu-common -lurcu \
                $(top_builddir)/src/common/health/libhealth.la \
                $(top_builddir)/src/common/config/libconfig.la \
                $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
This page took 0.023703 seconds and 4 git commands to generate.