Load relay daemon options from configuration file
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index a04b910f61d76eb264b3b02fccd0eba7aec94742..331b634b7bf03fa71e8ba0d5f902c3ad2d3f310c 100644 (file)
@@ -6,7 +6,14 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = lttng-relayd
 
-lttng_relayd_SOURCES = main.c lttng-relayd.h
+lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
+                       index.c index.h live.c live.h ctf-trace.c ctf-trace.h \
+                       cmd-generic.c cmd-generic.h \
+                       cmd-2-1.c cmd-2-1.h \
+                       cmd-2-2.c cmd-2-2.h \
+                       cmd-2-4.c cmd-2-4.h \
+                       health-relayd.c health-relayd.h \
+                       lttng-viewer.h
 
 # link on liblttngctl for check if relayd is already alive.
 lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
@@ -14,4 +21,7 @@ lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/compat/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/index/libindex.la \
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la
This page took 0.023914 seconds and 4 git commands to generate.