Load relay daemon options from configuration file
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index 853c21ae989014dd5bc8dab795a3a9961b13daac..331b634b7bf03fa71e8ba0d5f902c3ad2d3f310c 100644 (file)
@@ -7,10 +7,13 @@ AM_CFLAGS = -fno-strict-aliasing
 bin_PROGRAMS = lttng-relayd
 
 lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
-                       index.c index.h \
+                       index.c index.h live.c live.h ctf-trace.c ctf-trace.h \
                        cmd-generic.c cmd-generic.h \
                        cmd-2-1.c cmd-2-1.h \
-                       cmd-2-2.c cmd-2-2.h
+                       cmd-2-2.c cmd-2-2.h \
+                       cmd-2-4.c cmd-2-4.h \
+                       health-relayd.c health-relayd.h \
+                       lttng-viewer.h
 
 # link on liblttngctl for check if relayd is already alive.
 lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
@@ -19,4 +22,6 @@ lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
                $(top_builddir)/src/common/compat/libcompat.la \
-               $(top_builddir)/src/common/index/libindex.la
+               $(top_builddir)/src/common/index/libindex.la \
+               $(top_builddir)/src/common/health/libhealth.la \
+               $(top_builddir)/src/common/config/libconfig.la
This page took 0.024513 seconds and 4 git commands to generate.