Move to kernel style SPDX license identifiers
[lttng-tools.git] / src / bin / lttng-consumerd / Makefile.am
index a7971ade0336b7eafeaaee93498bb10377fefa88..112e360d0db40706915961bcba27bd6d2174bcc6 100644 (file)
@@ -1,16 +1,22 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+# SPDX-License-Identifier: GPL-2.0-only
 
 lttnglibexec_PROGRAMS = lttng-consumerd
 
-lttng_consumerd_SOURCES = lttng-consumerd.c lttng-consumerd.h
+lttng_consumerd_SOURCES = lttng-consumerd.c \
+       lttng-consumerd.h \
+       health-consumerd.h \
+       health-consumerd.c
 
 lttng_consumerd_LDADD = \
-          $(top_builddir)/src/common/libconsumer.la \
+          $(top_builddir)/src/common/consumer/libconsumer.la \
           $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
           $(top_builddir)/src/common/libcommon.la \
           $(top_builddir)/src/common/index/libindex.la \
-          -lrt
+          $(top_builddir)/src/common/health/libhealth.la \
+          $(top_builddir)/src/common/testpoint/libtestpoint.la
+
+lttng_consumerd_LDFLAGS = -rdynamic
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_consumerd_LDADD += -llttng-ust-ctl
+lttng_consumerd_LDADD += $(UST_CTL_LIBS)
 endif
This page took 0.023821 seconds and 4 git commands to generate.