vscode: Add configurations to run the executables under the debugger
[lttng-tools.git] / src / bin / Makefile.am
index ebf9b57ff938511d12091560a16c16ffa79c6a1c..146f273dea8f9f1e404a73166d0330f125b164e7 100644 (file)
@@ -1,7 +1,23 @@
-ACLOCAL_AMFLAGS = -I config
+# SPDX-License-Identifier: GPL-2.0-only
 
-SUBDIRS = lttng-consumerd \
-                 lttng \
-          lttng-sessiond \
-          lttng-relayd \
-          lttng-crash
+SUBDIRS =
+
+if BUILD_BIN_LTTNG
+SUBDIRS += lttng
+endif
+
+if BUILD_BIN_LTTNG_CONSUMERD
+SUBDIRS += lttng-consumerd
+endif
+
+if BUILD_BIN_LTTNG_CRASH
+SUBDIRS += lttng-crash
+endif
+
+if BUILD_BIN_LTTNG_RELAYD
+SUBDIRS += lttng-relayd
+endif
+
+if BUILD_BIN_LTTNG_SESSIOND
+SUBDIRS += lttng-sessiond
+endif
This page took 0.023492 seconds and 4 git commands to generate.