Change easter egg MSG to DBG
[lttng-tools.git] / lttng-sessiond / Makefile.am
index 15e28ce06c5bf469869584d6477caa5287bd8a00..592d55a13320e41d5caaad17387d5e7e4a21ca9f 100644 (file)
@@ -1,5 +1,6 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\" \
+                         -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
@@ -15,7 +16,7 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        hashtable.c hashtable.h \
                        compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
-                       kernel-ctl.c kernel-ctl.h \
+                       kernel.c kernel.h \
                        ust-ctl.h ust-app.h trace-ust.h \
                        context.c context.h \
                        channel.c channel.h \
@@ -23,6 +24,7 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
+                       lttng-ust-ctl.h lttng-ust-abi.h \
                        ../hashtable/rculfhash.c \
                        ../hashtable/rculfhash.h \
                        ../hashtable/hash.c ../hashtable/hash.h
@@ -41,5 +43,5 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                 $(top_builddir)/liblttngctl/liblttngctl.la
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_LDADD += -llttng-ust-comm -llttng-ust-ctl
+lttng_sessiond_LDADD += -llttng-ust-ctl
 endif
This page took 0.023822 seconds and 4 git commands to generate.