Basic hashtable support for UST
[lttng-tools.git] / ltt-sessiond / Makefile.am
index 0d284efb1ee4cc27f6155a24cdf29a7c8d3ca9d4..f3723016ea083a731e4b79bfd535cc07eeb44789 100644 (file)
@@ -12,6 +12,7 @@ COMPAT=compat/compat-poll.c
 endif
 
 ltt_sessiond_SOURCES = utils.c utils.h \
+                       hashtable.c hashtable.h \
                        compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        kernel-ctl.c kernel-ctl.h \
@@ -24,18 +25,21 @@ ltt_sessiond_SOURCES = utils.c utils.h \
                        session.c session.h \
                        ltt-sessiond.h main.c \
                        ../hashtable/rculfhash.c \
-                       ../hashtable/rculfhash.h
+                       ../hashtable/rculfhash.h \
+                       ../hashtable/hash.c ../hashtable/hash.h
 
 if LTTNG_TOOLS_HAVE_UST
 ltt_sessiond_SOURCES += \
                        trace-ust.c \
-                       ust-app.c \
-                       ust-comm.c ust-comm.h \
-                       ust-ctl.c
+                       ust-app.c
 endif
 
 # link on liblttngctl for check if sessiond is already alive.
-ltt_sessiond_LDADD = -lrt \
+ltt_sessiond_LDADD = -lrt -lurcu-cds -lurcu \
                 $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
                 $(top_builddir)/libkernelctl/libkernelctl.la \
                 $(top_builddir)/liblttngctl/liblttngctl.la
+
+if LTTNG_TOOLS_HAVE_UST
+ltt_sessiond_LDADD += -llttng-ust-comm -lustctl
+endif
This page took 0.02343 seconds and 4 git commands to generate.