Add TODO file
[lttng-tools.git] / ltt-sessiond / Makefile.am
index d19fe3caa7298d03e9eb511610f8f7e56d535c69..6f27963c3b046ef87f4ebc071cbc2e202c5d1d73 100644 (file)
@@ -5,7 +5,14 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
 ltt_sessiond_SOURCES = utils.c utils.h \
+                       compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        trace-ust.c trace-ust.h \
                        traceable-app.c traceable-app.h \
@@ -13,6 +20,8 @@ ltt_sessiond_SOURCES = utils.c utils.h \
                        ust-ctl.c ust-ctl.h \
                        kernel-ctl.c kernel-ctl.h \
                        context.c context.h \
+                       channel.c channel.h \
+                       event.c event.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
This page took 0.023843 seconds and 4 git commands to generate.