Add support for UST application registration
[lttng-tools.git] / ltt-sessiond / Makefile.am
index daa4265c1bda6e6ec7f210ec572980a25b0f7372..2f65a2fb87f96561e310c6af7572b9aee6471bb7 100644 (file)
@@ -1,15 +1,15 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include \
 AM_CPPFLAGS = -I$(top_srcdir)/include \
-                         -I$(top_srcdir)/libkernelctl -I$(top_srcdir)/libustctl \
-                         -DINSTALL_BIN_PATH=\"$(bindir)\"
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
 ltt_sessiond_SOURCES = utils.c trace.c session.c traceable-app.c ust-ctl.c \
 
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
 ltt_sessiond_SOURCES = utils.c trace.c session.c traceable-app.c ust-ctl.c \
-                       kernel-ctl.c context.c main.c \
+                       kernel-ctl.c context.c futex.c futex.h \
                        utils.h trace.h session.h traceable-app.h ust-ctl.h \
                        utils.h trace.h session.h traceable-app.h ust-ctl.h \
-                       context.h kernel-ctl.h ltt-sessiond.h
+                       ust-comm.c ust-comm.h \
+                       context.h kernel-ctl.h ltt-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = \
 
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = \
This page took 0.022862 seconds and 4 git commands to generate.