Fix: out of tree build fails on missing header
[lttng-tools.git] / include / Makefile.am
index bc105b0649c482d0959aa35325c8cdc8909f3733..7a3535b3049d21e730d7205ad1c543cf35be1767 100644 (file)
@@ -21,7 +21,7 @@ version.h:
                ##
                ## Check whether we are in a git repo.
                ##
-               git_describe="$$($(GIT_DESCRIBE_CMD) 2>/dev/null)"; \
+               git_describe="`$(GIT_DESCRIBE_CMD) 2>/dev/null`"; \
                if [ $$? -eq 0 ]; then \
                        git_version="$${git_describe}"; \
                else \
@@ -78,6 +78,7 @@ lttnginclude_HEADERS = \
        lttng/save.h \
        lttng/load.h \
        lttng/endpoint.h \
+       lttng/rotation.h \
        version.h.tmpl
 
 lttngactioninclude_HEADERS= \
@@ -109,4 +110,6 @@ noinst_HEADERS = \
        lttng/notification/notification-internal.h \
        lttng/trigger/trigger-internal.h \
        lttng/endpoint-internal.h \
-       lttng/notification/channel-internal.h
+       lttng/notification/channel-internal.h \
+       lttng/channel-internal.h \
+       lttng/rotate-internal.h
This page took 0.023307 seconds and 4 git commands to generate.