.gitignore: ignore local vscode workspace settings file
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index 73428d9bef9b54fdd208ced14e09b1c2a4b392f6..d9cdd680d52756541314116896996ee02a5c500f 100644 (file)
@@ -7,8 +7,18 @@ lttng.i: lttng.i.in
 # `swig_this` shadows a global of the same name.  Later versions (like 4.0.1)
 # have renamed this global to `Swig_This_global`.
 #
-# Disable -Wshadow for that file.
-AM_CFLAGS += -Wno-shadow
+# Disable some warning flags for that file.
+AM_CFLAGS += \
+       -Wno-cast-function-type \
+       -Wno-missing-field-initializers \
+       -Wno-null-dereference \
+       -Wno-redundant-decls \
+       -Wno-shadow \
+       -Wno-unused-parameter
+
+# Swig regularily changes and generates code that results warnings which break
+# Werror builds. Disable that option for this sub-project.
+AM_CFLAGS += -Wno-error
 
 AM_CPPFLAGS += $(PYTHON_INCLUDE)
 
@@ -21,9 +31,14 @@ MAINTAINERCLEANFILES = lttng_wrap.c lttng.py
 nodist__lttng_la_SOURCES = lttng_wrap.c
 _lttng_la_LDFLAGS = -module
 _lttng_la_LIBADD =     $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la               \
-                       $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la            \
+                       $(top_builddir)/src/common/libsessiond-comm.la          \
                        $(top_builddir)/src/common/libcommon-gpl.la
 
+# Use this fake source file to force the link mode of the library
+# from gcc to g++. The library contains only C code, but depends on
+# libstdc++.
+nodist_EXTRA__lttng_la_SOURCES = dummy.cpp
+
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
 
This page took 0.023899 seconds and 4 git commands to generate.