.gitignore: ignore local vscode workspace settings file
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index 29914e5cd5404e131393e310efaf8efe9ed53d97..d9cdd680d52756541314116896996ee02a5c500f 100644 (file)
@@ -11,6 +11,7 @@ lttng.i: lttng.i.in
 AM_CFLAGS += \
        -Wno-cast-function-type \
        -Wno-missing-field-initializers \
+       -Wno-null-dereference \
        -Wno-redundant-decls \
        -Wno-shadow \
        -Wno-unused-parameter
@@ -33,6 +34,11 @@ _lttng_la_LIBADD =   $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la               \
                        $(top_builddir)/src/common/libsessiond-comm.la          \
                        $(top_builddir)/src/common/libcommon-gpl.la
 
+# Use this fake source file to force the link mode of the library
+# from gcc to g++. The library contains only C code, but depends on
+# libstdc++.
+nodist_EXTRA__lttng_la_SOURCES = dummy.cpp
+
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
 
This page took 0.028037 seconds and 4 git commands to generate.