OOT build fix: asciidoc.conf is now a source file
[lttng-tools.git] / doc / man / Makefile.am
index 075ab8ba0f0f36bf8987c0787e0faa152fdc8f3b..1090f1ac11a910904c91129c197af7f8bbcc3310 100644 (file)
@@ -53,6 +53,7 @@ COMMON_TXT = \
 
 # config
 ASCIIDOC_CONF = $(srcdir)/asciidoc.conf
+ASCIIDOC_ATTRS_CONF = $(builddir)/asciidoc-attrs.conf
 XSL_FILES = \
        manpage.xsl \
        manpage-callouts.xsl \
@@ -76,7 +77,7 @@ if MAN_PAGES_OPT
 # at this point, we know the user asked to build the man pages
 if HAVE_ASCIIDOC_XMLTO
 # tools
-ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -d manpage
+ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -f $(ASCIIDOC_ATTRS_CONF) -d manpage
 ADOC_DOCBOOK = $(ADOC) -b docbook
 XTO = $(XMLTO) -m $(firstword $(XSL_SRC_FILES)) man
 
@@ -140,4 +141,5 @@ dist-hook:
 endif # !MAN_PAGES_OPT
 
 # always distribute the source files
-EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) $(ASCIIDOC_CONF).in
+EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) \
+       $(ASCIIDOC_CONF) $(ASCIIDOC_ATTRS_CONF).in
This page took 0.023425 seconds and 4 git commands to generate.