fix build and out of tree build
[ust.git] / ustd / Makefile.am
index 723b9dfe40843e06926baf9b55acdfd1efc57438..c4b156723b045e377f36f425f797bdfa072a4af9 100644 (file)
@@ -1,9 +1,7 @@
+AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
+       -I$(top_srcdir)/include
+
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c localerr.h ustd.c ustd.h $(top_builddir)/libustcomm/ustcomm.c $(top_builddir)/libustcomm/ustcomm.h $(top_builddir)/share/kref.c
+ustd_SOURCES = lowlevel.c ustd.c ustd.h $(top_srcdir)/libustcomm/ustcomm.c $(top_srcdir)/libustcomm/ustcomm.h
 ustd_LDFLAGS = -lpthread
-
-INCLUDES = -I$(top_builddir)/share
-INCLUDES += -I@URCU_PATH@
-INCLUDES += -I@KCOMPAT_PATH@
-INCLUDES += -I$(top_builddir)/libust
-INCLUDES += -I$(top_builddir)/libustcomm
+ustd_CFLAGS = -DUST_COMPONENT=ustd
This page took 0.022311 seconds and 4 git commands to generate.