make libustcomm into a static lib
[ust.git] / ustd / Makefile.am
index 6adad644b36b0f002a51df336b500d441d178c44..96f167b0e1a3e533f4911975e8e6b1f34d93f5a6 100644 (file)
@@ -2,7 +2,12 @@ AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
        -I$(top_srcdir)/include
 
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c ustd.c ustd.h $(top_srcdir)/libustcomm/ustcomm.c $(top_srcdir)/libustcomm/ustcomm.h
-ustd_LDADD = $(top_builddir)/snprintf/libustsnprintf.la
+
+ustd_SOURCES = lowlevel.c ustd.c ustd.h
+
+ustd_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
 ustd_LDFLAGS = -lpthread
 ustd_CFLAGS = -DUST_COMPONENT=ustd
This page took 0.022245 seconds and 4 git commands to generate.