make libustcomm into a static lib
[ust.git] / ustctl / Makefile.am
index 91966f0d6752e964aa7708ac5bd588ce9f7a1350..4b8100f77f2a4c65f00d64cff67c750836902c59 100644 (file)
@@ -2,6 +2,14 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm \
        -I$(top_srcdir)/libustcmd $(KCOMPAT_CFLAGS)
 
 bin_PROGRAMS = ustctl
-ustctl_SOURCES = ustctl.c $(top_srcdir)/libustcomm/ustcomm.c $(top_srcdir)/libustcomm/ustcomm.h $(top_srcdir)/libustcmd/ustcmd.c $(top_srcdir)/libustcmd/ustcmd.h
+
+ustctl_SOURCES = \
+       ustctl.c \
+       $(top_srcdir)/libustcmd/ustcmd.c \
+       $(top_srcdir)/libustcmd/ustcmd.h
+
 ustctl_CFLAGS = -DUST_COMPONENT=ustctl
-ustctl_LDADD = $(top_builddir)/snprintf/libustsnprintf.la
+
+ustctl_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
This page took 0.022868 seconds and 4 git commands to generate.