Update version to 0.16
[ust.git] / ustctl / Makefile.am
index a27880a03404ae3dd7642ac77ab9a4b3fd552720..1e442a3fbc863dea4b6dd0271c9709eb541ebb46 100644 (file)
@@ -1,8 +1,15 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm \
+       -I$(top_srcdir)/libustctl $(KCOMPAT_CFLAGS)
+AM_CFLAGS = -fno-strict-aliasing
+
 bin_PROGRAMS = ustctl
-ustctl_SOURCES = ustctl.c $(top_builddir)/libustcomm/ustcomm.c $(top_builddir)/libustcomm/ustcomm.h $(top_builddir)/libustcmd/ustcmd.c $(top_builddir)/libustcmd/ustcmd.h $(top_builddir)/share/usterr.h
-ustctl_CFLAGS = -DUST_COMPONENT=ustctl
 
-INCLUDES = $(KCOMPAT_CFLAGS)
-INCLUDES += -I$(top_builddir)/libustcomm
-INCLUDES += -I$(top_builddir)/libustcmd
-INCLUDES += -I$(top_builddir)/share
+ustctl_SOURCES = \
+       ustctl.c marker_cmds.c trace_cmds.c channel_cmds.c cli.c cli.h scanning_functions.c scanning_functions.h
+
+ustctl_CFLAGS = -DUST_COMPONENT=ustctl -fno-strict-aliasing
+
+ustctl_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la \
+       $(top_builddir)/libustctl/libustctl.la
This page took 0.02224 seconds and 4 git commands to generate.