Update version to 0.16
[ust.git] / ustctl / Makefile.am
index 380405b250dac6debcb09bbdc26dec634636e67d..1e442a3fbc863dea4b6dd0271c9709eb541ebb46 100644 (file)
@@ -1,7 +1,15 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm \
-       -I$(top_srcdir)/libustcmd $(KCOMPAT_CFLAGS)
+       -I$(top_srcdir)/libustctl $(KCOMPAT_CFLAGS)
+AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ustctl
-ustctl_SOURCES = ustctl.c $(top_srcdir)/libustcomm/ustcomm.c $(top_srcdir)/libustcomm/ustcomm.h $(top_srcdir)/libustcmd/ustcmd.c $(top_srcdir)/libustcmd/ustcmd.h
-ustctl_CFLAGS = -DUST_COMPONENT=ustctl
 
+ustctl_SOURCES = \
+       ustctl.c marker_cmds.c trace_cmds.c channel_cmds.c cli.c cli.h scanning_functions.c scanning_functions.h
+
+ustctl_CFLAGS = -DUST_COMPONENT=ustctl -fno-strict-aliasing
+
+ustctl_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la \
+       $(top_builddir)/libustctl/libustctl.la
This page took 0.022448 seconds and 4 git commands to generate.