Function tests for libustcmd and a C tap library
[ust.git] / tests / Makefile.am
index 69801c0162a1bf24996de59a18469258492e2431..526f81c789964bf545bd1e91d89dddac3e9ad498 100644 (file)
@@ -1,3 +1,14 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint
+SUBDIRS = . hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint ustcmd_function_tests
 
 dist_noinst_SCRIPTS = test_loop runtests trace_matches
+
+lib_LTLIBRARIES = libtap.la
+
+libtap_la_SOURCES = \
+       tap.c \
+       tap.h
+
+libtap_la_LDFLAGS = -no-undefined -version-info 0:0:0
+
+libtap_la_LIBADD = \
+       -lpthread
\ No newline at end of file
This page took 0.022682 seconds and 4 git commands to generate.