Removing NO_IPI ifdef for memory barrier. The smp_wmb should be used all the time...
[ust.git] / libust / Makefile.am
index b4d059803fa5deb1078ac845068bf9ad5360ca75..e357ad16496e0f719a0618a776423e77768860d7 100644 (file)
@@ -1,4 +1,5 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+AM_CFLAGS = -fno-strict-aliasing
 
 lib_LTLIBRARIES = libust.la
 
@@ -19,13 +20,15 @@ libust_la_SOURCES = \
        tracectl.c \
        $(top_builddir)/libustcomm/multipoll.c \
        tracerconst.h \
-       header-inline.h
+       header-inline.h \
+       type-serializer.c
 
 libust_la_LDFLAGS = -no-undefined -version-info 0:0:0
 
 libust_la_LIBADD = \
        -lpthread \
+       -lrt \
        $(top_builddir)/snprintf/libustsnprintf.la \
        $(top_builddir)/libustcomm/libustcomm.la
 
-libust_la_CFLAGS = -DUST_COMPONENT="libust"
+libust_la_CFLAGS = -DUST_COMPONENT="libust" -fno-strict-aliasing
This page took 0.031737 seconds and 4 git commands to generate.