make libustcomm into a static lib
[ust.git] / libust / Makefile.am
index e38956a9f4bd60f66838286964691cade7e5c4a5..cb5dc1291511d4a34a80439111dc466a58e19fa3 100644 (file)
@@ -1,6 +1,7 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
 
 lib_LTLIBRARIES = libust.la
+
 libust_la_SOURCES = \
        marker.c \
        tracepoint.c \
@@ -16,9 +17,14 @@ libust_la_SOURCES = \
        tracercore.h \
        serialize.c \
        tracectl.c \
-       $(top_builddir)/libustcomm/ustcomm.c \
        tracerconst.h \
        header-inline.h
+
 libust_la_LDFLAGS = -no-undefined -version-info 0:0:0
-libust_la_LIBADD = -lpthread $(top_builddir)/snprintf/libustsnprintf.la
+
+libust_la_LIBADD = \
+       -lpthread \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
 libust_la_CFLAGS = -DUST_COMPONENT="libust"
This page took 0.023849 seconds and 4 git commands to generate.