Update version to 0.16
[ust.git] / libust / Makefile.am
index e38956a9f4bd60f66838286964691cade7e5c4a5..44addf0d92f1536acf00cd7f167315f662caa71f 100644 (file)
@@ -1,9 +1,12 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+AM_CFLAGS = -fno-strict-aliasing
 
 lib_LTLIBRARIES = libust.la
+
 libust_la_SOURCES = \
        marker.c \
        tracepoint.c \
+       trace_event.c \
        channels.c \
        channels.h \
        marker-control.c \
@@ -16,9 +19,16 @@ libust_la_SOURCES = \
        tracercore.h \
        serialize.c \
        tracectl.c \
-       $(top_builddir)/libustcomm/ustcomm.c \
        tracerconst.h \
-       header-inline.h
+       type-serializer.h \
+       type-serializer.c
+
 libust_la_LDFLAGS = -no-undefined -version-info 0:0:0
-libust_la_LIBADD = -lpthread $(top_builddir)/snprintf/libustsnprintf.la
-libust_la_CFLAGS = -DUST_COMPONENT="libust"
+
+libust_la_LIBADD = \
+       -lpthread \
+       -lrt \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
+libust_la_CFLAGS = -DUST_COMPONENT="libust" -fno-strict-aliasing
This page took 0.022922 seconds and 4 git commands to generate.