Update version to 0.16
[ust.git] / libust / Makefile.am
index e23b5c941d3af47d487b8c3020a2691b977babbd..44addf0d92f1536acf00cd7f167315f662caa71f 100644 (file)
@@ -1,7 +1,34 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+AM_CFLAGS = -fno-strict-aliasing
 
 lib_LTLIBRARIES = libust.la
-libust_la_SOURCES = buffer.h marker.c tracepoint.c channels.c channels.h marker-control.c marker-control.h relay.c relay.h tracer.c tracercore.c tracercore.h serialize.c tracectl.c $(top_builddir)/libustcomm/ustcomm.c
+
+libust_la_SOURCES = \
+       marker.c \
+       tracepoint.c \
+       trace_event.c \
+       channels.c \
+       channels.h \
+       marker-control.c \
+       marker-control.h \
+       buffers.c \
+       buffers.h \
+       tracer.c \
+       tracer.h \
+       tracercore.c \
+       tracercore.h \
+       serialize.c \
+       tracectl.c \
+       tracerconst.h \
+       type-serializer.h \
+       type-serializer.c
+
 libust_la_LDFLAGS = -no-undefined -version-info 0:0:0
-libust_la_LIBADD = -lpthread
-libust_la_CFLAGS = -DUST_COMPONENT="libust"
+
+libust_la_LIBADD = \
+       -lpthread \
+       -lrt \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
+libust_la_CFLAGS = -DUST_COMPONENT="libust" -fno-strict-aliasing
This page took 0.022637 seconds and 4 git commands to generate.