Update version to 0.16
[ust.git] / java / Makefile.am
index fa536287827edd13db88a8bc8d0209309a92ba7e..4dcb0c3aff20b315b4a0164578238fe2554b9af9 100644 (file)
@@ -1,15 +1,17 @@
-AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_builddir)/libust
+AM_CPPFLAGS = -I$(top_srcdir)/include
 
 lib_LTLIBRARIES = libustjava.la
 libustjava_la_SOURCES = UST.c UST.h
-noinst_DATA = UST.java
+dist_noinst_DATA = UST.java
 libustjava_la_LIBADD = -lc -L$(top_builddir)/libust/.libs -lust
 
-all: UST.class
+all: UST.class UST.h
 
 clean-local:
        rm -rf UST.h UST.class
 
 UST.class: UST.java
-       javac UST.java
+       javac -d "$(builddir)" "$(srcdir)/UST.java"
 
+UST.h:
+       javah -jni UST
This page took 0.023048 seconds and 4 git commands to generate.