Make buildsystem use pkg-config to search for kcompat and liburcu
[ust.git] / hello / Makefile.am
index 63e30b16980b45893a41277ddb4c1ea1c5dd6601..85b04b6679c23913a7421c62fa164eddb0f01755 100644 (file)
@@ -1,8 +1,6 @@
+INCLUDES = -I$(top_builddir)/share -I$(top_builddir)/libust \
+       $(KCOMPAT_CFLAGS) $(URCU_CFLAGS)
+
 noinst_PROGRAMS = hello
 hello_SOURCES = hello.c tp.c tp.h
-hello_LDADD = $(top_builddir)/libust/libust.la @URCU_PATH@@URCU_LIB@
-
-INCLUDES = -I$(top_builddir)/share
-INCLUDES += -I@URCU_PATH@
-INCLUDES += -I@KCOMPAT_PATH@
-INCLUDES += -I$(top_builddir)/libust
+hello_LDADD = $(top_builddir)/libust/libust.la $(URCU_LIBS)
This page took 0.023604 seconds and 4 git commands to generate.