Create a LttvEvent object
[lttv.git] / lttv / lttv / Makefile.am
index 6bc11e0860bbf577e24b39763b0176452b5d2c32..b273d47574cd3cd015a04c3469835223d4c31e4f 100644 (file)
@@ -1,5 +1,4 @@
-#Disabled by Mathieu Desnoyers: Build issue on x86_64 (FIXME)
-#SUBDIRS= sync
+SUBDIRS= sync
 
 AM_CFLAGS= $(PACKAGE_CFLAGS)
 LDADD = $(POPT_LIBS) $(M_LIBS) $(GLPK_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
@@ -55,22 +54,40 @@ lttv_real_SOURCES = \
        tracecontext.c\
        traceset.c\
        filter.c\
-       print.c
-
-#Disabled by Mathieu Desnoyers (does not build on x86_64)
-#      sync/sync_chain.c\
-#      sync/sync_chain_lttv.c\
-#      sync/graph_functions.c\
-#      sync/data_structures.c\
-#      sync/event_processing_lttng_common.c\
-#      sync/event_processing_lttng_standard.c\
-#      sync/event_processing_lttng_null.c\
-#      sync/event_matching_broadcast.c\
-#      sync/event_matching_distributor.c\
-#      sync/event_matching_tcp.c\
-#      sync/event_analysis_chull.c\
-#      sync/event_analysis_eval.c\
-#      sync/event_analysis_linreg.c
+       print.c\
+       sync/sync_chain.c\
+       sync/sync_chain.h\
+       sync/sync_chain_lttv.c\
+       sync/sync_chain_lttv.h\
+       sync/graph_functions.c\
+       sync/graph_functions.h\
+       sync/data_structures.c\
+       sync/data_structures.h\
+       sync/event_processing.h\
+       sync/event_processing_lttng_common.c\
+       sync/event_processing_lttng_common.h\
+       sync/event_processing_lttng_standard.c\
+       sync/event_processing_lttng_standard.h\
+       sync/event_processing_lttng_null.c\
+       sync/event_processing_lttng_null.h\
+       sync/event_matching.h\
+       sync/event_matching_broadcast.c\
+       sync/event_matching_broadcast.h\
+       sync/event_matching_distributor.c\
+       sync/event_matching_distributor.h\
+       sync/event_matching_tcp.c\
+       sync/event_matching_tcp.h\
+       sync/event_analysis.h\
+       sync/event_analysis_chull.c\
+       sync/event_analysis_chull.h\
+       sync/event_analysis_eval.c\
+       sync/event_analysis_eval.h\
+       sync/event_analysis_linreg.c\
+       sync/event_analysis_linreg.h\
+       sync/factor_reduction.h\
+       sync/factor_reduction_accuracy.c\
+       sync/factor_reduction_accuracy.h\
+       sync/lookup3.h
 
 lttvinclude_HEADERS = \
        attribute.h\
@@ -84,7 +101,8 @@ lttvinclude_HEADERS = \
        tracecontext.h\
        traceset.h\
        filter.h\
-       print.h
+       print.h\
+       event.h
 
 #man_MANS = lttv.1
 #EXTRA_DIST = lttv.1
This page took 0.023119 seconds and 4 git commands to generate.