Create a LttvEvent object
[lttv.git] / lttv / lttv / Makefile.am
index 4129f4b0c6f035dc894d74896decc04e7c96227d..b273d47574cd3cd015a04c3469835223d4c31e4f 100644 (file)
@@ -1,5 +1,7 @@
+SUBDIRS= sync
+
 AM_CFLAGS= $(PACKAGE_CFLAGS)
-LDADD = $(POPT_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
+LDADD = $(POPT_LIBS) $(M_LIBS) $(GLPK_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
 
 bin_PROGRAMS = lttv.real
 
@@ -52,7 +54,55 @@ lttv_real_SOURCES = \
        tracecontext.c\
        traceset.c\
        filter.c\
-       print.c
+       print.c\
+       sync/sync_chain.c\
+       sync/sync_chain.h\
+       sync/sync_chain_lttv.c\
+       sync/sync_chain_lttv.h\
+       sync/graph_functions.c\
+       sync/graph_functions.h\
+       sync/data_structures.c\
+       sync/data_structures.h\
+       sync/event_processing.h\
+       sync/event_processing_lttng_common.c\
+       sync/event_processing_lttng_common.h\
+       sync/event_processing_lttng_standard.c\
+       sync/event_processing_lttng_standard.h\
+       sync/event_processing_lttng_null.c\
+       sync/event_processing_lttng_null.h\
+       sync/event_matching.h\
+       sync/event_matching_broadcast.c\
+       sync/event_matching_broadcast.h\
+       sync/event_matching_distributor.c\
+       sync/event_matching_distributor.h\
+       sync/event_matching_tcp.c\
+       sync/event_matching_tcp.h\
+       sync/event_analysis.h\
+       sync/event_analysis_chull.c\
+       sync/event_analysis_chull.h\
+       sync/event_analysis_eval.c\
+       sync/event_analysis_eval.h\
+       sync/event_analysis_linreg.c\
+       sync/event_analysis_linreg.h\
+       sync/factor_reduction.h\
+       sync/factor_reduction_accuracy.c\
+       sync/factor_reduction_accuracy.h\
+       sync/lookup3.h
+
+lttvinclude_HEADERS = \
+       attribute.h\
+       hook.h\
+       iattribute.h\
+       lttv.h\
+       module.h\
+       option.h\
+       state.h\
+       stats.h\
+       tracecontext.h\
+       traceset.h\
+       filter.h\
+       print.h\
+       event.h
 
 #man_MANS = lttv.1
 #EXTRA_DIST = lttv.1
This page took 0.022563 seconds and 4 git commands to generate.