lttng: move parse_userspace_probe_opts to a common util
[lttng-tools.git] / src / bin / lttng / Makefile.am
index c75601f21ad3b1602606635e52e9d3c09103b98f..c630c6d5cb3ad963052dcd9bc229f7e5954c2b6e 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 if EMBED_HELP
@@ -27,7 +29,10 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/enable_rotation.c \
                                commands/disable_rotation.c \
                                commands/clear.c \
-                               utils.c utils.h lttng.c
+                               loglevel.c loglevel.h \
+                               utils.c utils.h \
+                               lttng.c \
+                               uprobe.c uprobe.h
 
 lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
 
@@ -35,4 +40,5 @@ lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
                        $(top_builddir)/src/common/config/libconfig.la \
                        $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(top_builddir)/src/common/filter/libfilter.la \
                        $(POPT_LIBS)
This page took 0.022766 seconds and 4 git commands to generate.