library mass rename: add lttng- prefix
[ust.git] / liblttng-ust-java / Makefile.am
diff --git a/liblttng-ust-java/Makefile.am b/liblttng-ust-java/Makefile.am
new file mode 100644 (file)
index 0000000..fb25cb7
--- /dev/null
@@ -0,0 +1,21 @@
+if BUILD_JNI_INTERFACE
+
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+lib_LTLIBRARIES = liblttng-ust-java.la
+liblttng_ust_java_la_SOURCES = UST.c UST.h ust_java.h
+dist_noinst_DATA = UST.java
+liblttng_ust_java_la_LIBADD = -lc -L$(top_builddir)/liblttng-ust/.libs -llttng-ust
+
+all: UST.class UST.h
+
+clean-local:
+       rm -rf UST.h UST.class
+
+UST.class: UST.java
+       javac -d "$(builddir)" "$(srcdir)/UST.java"
+
+UST.h: UST.class
+       javah -jni UST
+
+endif
This page took 0.028483 seconds and 4 git commands to generate.