Fix: examples make distcheck failure
[userspace-rcu.git] / doc / examples / Makefile.am
index d8a76fed6f70d515bdc4122f0baea553c8c619c4..84ed049ab73a38a963c24da36cb22e5c67a70f12 100644 (file)
@@ -123,9 +123,12 @@ SUBDIRS_PROXY = hlist list urcu-flavors wfcqueue rculfqueue \
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                cp -pfR $(srcdir)/dist-files $(builddir); \
+               chmod -R u+w $(builddir)/dist-files; \
                cp -pf $(srcdir)/Makefile.examples.template $(builddir); \
+               chmod u+w $(builddir)/Makefile.examples.template; \
                for subdir in $(SUBDIRS_PROXY); do \
                        cp -pfR $(srcdir)/$$subdir $(builddir); \
+                       chmod -R u+w $(builddir)/$$subdir; \
                done; \
        fi; \
        if [ x"$(shell echo "$(top_srcdir)" | grep "^/" | wc -l)" = x"1" ]; then \
This page took 0.02218 seconds and 4 git commands to generate.