Add pretty_xml utils
[lttng-tools.git] / tests / utils / xml-utils / Makefile.am
index 9b00f7027591c415a6b813257db51026fde0e75f..7fac127281f1075438b6044857d6e2e68c89a598 100644 (file)
@@ -1,6 +1,6 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-noinst_PROGRAMS = validate_xml extract_xml
+noinst_PROGRAMS = validate_xml extract_xml pretty_xml
 validate_xml_SOURCES = validate_xml.c
 validate_xml_CPPFLAGS = $(libxml2_CFLAGS) $(AM_CPPFLAGS)
 validate_xml_LDADD = $(libxml2_LIBS)
@@ -9,6 +9,10 @@ extract_xml_SOURCES = extract_xml.c
 extract_xml_CPPFLAGS = $(libxml2_CFLAGS) $(AM_CPPFLAGS)
 extract_xml_LDADD = $(libxml2_LIBS)
 
+pretty_xml_SOURCES = pretty_xml.c
+pretty_xml_CPPFLAGS = $(libxml2_CFLAGS) $(AM_CPPFLAGS)
+pretty_xml_LDADD = $(libxml2_LIBS)
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.023147 seconds and 4 git commands to generate.