tests: compile some tools/tests as C++
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index b3212228fe2a6a852c6e125a4ba4ee9cd486e321..cb869715dd47280f084de8a5a7f2699efe46e338 100644 (file)
@@ -1,16 +1,15 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) \
-               -I$(top_srcdir)/tests/utils -O2 -g
+# SPDX-License-Identifier: GPL-2.0-only
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
+AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils \
+       -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents
-gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp \
-               $(top_builddir)/tests/utils/libtestutils.la
+gen_ust_nevents_SOURCES = \
+       gen-ust-nevents.cpp \
+       tp.c \
+       tp.h
+gen_ust_nevents_LDADD = $(UST_LIBS) \
+               $(top_builddir)/tests/utils/libtestutils.la \
+               $(DL_LIBS)
 endif
This page took 0.023491 seconds and 4 git commands to generate.