tests: compile some tools/tests as C++
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index 33c2d41efa8795b960ea08ccc864373a7fbeaf06..cb869715dd47280f084de8a5a7f2699efe46e338 100644 (file)
@@ -1,10 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils \
        -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents
-gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp \
+gen_ust_nevents_SOURCES = \
+       gen-ust-nevents.cpp \
+       tp.c \
+       tp.h
+gen_ust_nevents_LDADD = $(UST_LIBS) \
                $(top_builddir)/tests/utils/libtestutils.la \
                $(DL_LIBS)
 endif
This page took 0.023235 seconds and 4 git commands to generate.