Tests: utils: add gen-ust-nevents-str util
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents-str / Makefile.am
diff --git a/tests/utils/testapp/gen-ust-nevents-str/Makefile.am b/tests/utils/testapp/gen-ust-nevents-str/Makefile.am
new file mode 100644 (file)
index 0000000..57f8350
--- /dev/null
@@ -0,0 +1,16 @@
+AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) \
+               -I$(top_srcdir)/tests/utils -O2 -g
+
+if LTTNG_TOOLS_BUILD_WITH_LIBDL
+LIBS += -ldl
+endif
+if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
+LIBS += -lc
+endif
+
+if HAVE_LIBLTTNG_UST_CTL
+noinst_PROGRAMS = gen-ust-nevents-str
+gen_ust_nevents_str_SOURCES = gen-ust-nevents-str.c tp.c tp.h
+gen_ust_nevents_str_LDADD = -llttng-ust -lurcu-bp \
+               $(top_builddir)/tests/utils/libtestutils.la
+endif
This page took 0.023195 seconds and 4 git commands to generate.