configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / utils / testapp / gen-ust-events-ns / Makefile.am
index 2e3ad0747ff767f512df37fefc1515f1d177565b..37bdc94fe786f3c7bfb2e1420e40ea1377b563ca 100644 (file)
@@ -4,6 +4,13 @@ AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
               -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
+# Disable some warnings flags to accomodate the tracepoint headers
+WARN_FLAGS = \
+       -Wno-redundant-decls
+
+AM_CFLAGS += $(WARN_FLAGS)
+AM_CXXFLAGS += $(WARN_FLAGS)
+
 noinst_PROGRAMS = gen-ust-events-ns
 gen_ust_events_ns_SOURCES = \
        gen-ust-events-ns.cpp \
This page took 0.022968 seconds and 4 git commands to generate.