tests: Handle test failures for ust-constructors with heap allocation
[lttng-tools.git] / tests / utils / testapp / gen-ust-events-constructor / Makefile.am
index 4e7e1e1021576da8db846e4d074b411ec9851608..b323baee2f2fb449f0644d0890fc707063c8e603 100644 (file)
@@ -48,9 +48,9 @@ libtp_a_define_la_SOURCES = \
        tp-a-define.cpp \
        tp-a.h
 
-noinst_PROGRAMS = gen-ust-events-constructor
-gen_ust_events_constructor_SOURCES = \
-       main.cpp \
+noinst_PROGRAMS = gen-ust-events-constructor \
+       uses_heap
+gen_ust_events_constructor_SOURCES = main.cpp \
        01-tp-before-define.cpp \
        02-define-tp.cpp \
        03-tp-after-define.cpp \
@@ -66,4 +66,6 @@ gen_ust_events_constructor_LDADD = $(UST_LIBS) \
                $(builddir)/libtp-a-provider.la \
                $(top_builddir)/tests/utils/libtestutils.la \
                $(DL_LIBS)
+
+uses_heap_SOURCES = uses_heap.cpp
 endif
This page took 0.023437 seconds and 4 git commands to generate.