Tests: Move python test app to `tests/utils/testapp` directory
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index e2ad1f2355f6c1f4a3c2fab8a8821d8a98526f5f..dcb83d2d96754bae8141315b634ff88af373521d 100644 (file)
@@ -1,11 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0-only
 SUBDIRS = \
-         gen-ns-events \
+         gen-kernel-test-events \
+         gen-py-events \
+         gen-syscall-events \
          gen-ust-events \
-         gen-ust-events-ns \
          gen-ust-nevents \
          gen-ust-nevents-str \
          gen-ust-tracef \
-         gen-syscall-events \
          userspace-probe-elf-binary
 
 if CXX_WORKS
@@ -20,4 +21,10 @@ if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 SUBDIRS += gen-syscall-events-callstack
 endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
+if IS_LINUX
+SUBDIRS += \
+         gen-ns-events \
+         gen-ust-events-ns
+endif # IS_LINUX
+
 noinst_HEADERS = signal-helper.h
This page took 0.023734 seconds and 4 git commands to generate.