Tests: Move python test app to `tests/utils/testapp` directory
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index 9bfe53666b260d8c6d252a652353b10e31e7213a..dcb83d2d96754bae8141315b634ff88af373521d 100644 (file)
@@ -1,11 +1,30 @@
-SUBDIRS = gen-ust-events \
+# SPDX-License-Identifier: GPL-2.0-only
+SUBDIRS = \
+         gen-kernel-test-events \
+         gen-py-events \
+         gen-syscall-events \
+         gen-ust-events \
          gen-ust-nevents \
          gen-ust-nevents-str \
          gen-ust-tracef \
-         gen-syscall-events
+         userspace-probe-elf-binary
+
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if TEST_SDT_UPROBE
+SUBDIRS += userspace-probe-sdt-binary
+endif # TEST_SDT_UPROBE
 
 if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 SUBDIRS += gen-syscall-events-callstack
 endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
+if IS_LINUX
+SUBDIRS += \
+         gen-ns-events \
+         gen-ust-events-ns
+endif # IS_LINUX
+
 noinst_HEADERS = signal-helper.h
This page took 0.024083 seconds and 4 git commands to generate.