tests: Replace babelstats.pl with bt2 plugins
[lttng-tools.git] / tests / utils / bt2_plugins / Makefile.am
diff --git a/tests/utils/bt2_plugins/Makefile.am b/tests/utils/bt2_plugins/Makefile.am
new file mode 100644 (file)
index 0000000..59fdbcb
--- /dev/null
@@ -0,0 +1,28 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+SUBDIRS = event_name field_stats
+
+AM_CPPFLAGS += -I$(srcdir)
+AM_CXXFLAGS += $(babeltrace2_CFLAGS) \
+       $(WARN_FLAGS)
+
+noinst_LTLIBRARIES = lttngtest.la
+
+# lttng-tools uses -fvisibility=hidden by default, but to
+# produce a loadable plugin some of the symbols must not be
+# hidden. Override the `-fvisibility` for this shared object.
+lttngtest_la_CXXFLAGS = \
+       $(AM_CXXFLAGS) \
+       -fvisibility=default
+
+lttngtest_la_SOURCES = \
+       lttngtest-plugin.cpp
+
+lttngtest_la_LDFLAGS = \
+       $(AM_LDFLAGS) \
+       $(LD_NO_UNDEFINED) \
+       -rpath / -avoid-version -module $(LD_NOTEXT)
+
+lttngtest_la_LIBADD = \
+       event_name/event_name.la \
+       field_stats/field_stats.la
This page took 0.026935 seconds and 4 git commands to generate.