Add libconfig implementation and tests
[lttng-tools.git] / tests / unit / ini_config / Makefile.am
diff --git a/tests/unit/ini_config/Makefile.am b/tests/unit/ini_config/Makefile.am
new file mode 100644 (file)
index 0000000..98956f7
--- /dev/null
@@ -0,0 +1,26 @@
+AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/utils/
+
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+LIBCONFIG=$(top_builddir)/src/common/config/libconfig.la
+LIBCOMMON=$(top_builddir)/src/common/libcommon.la
+LIBHASHTABLE=$(top_builddir)/src/common/hashtable/libhashtable.la
+
+noinst_PROGRAMS = ini_config
+EXTRA_DIST = test_ini_config
+
+ini_config_SOURCES = ini_config.c
+ini_config_LDADD = $(LIBTAP) $(LIBCONFIG) $(LIBCOMMON) $(LIBHASHTABLE)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022936 seconds and 4 git commands to generate.