Add UST and kernel streaming tests
[lttng-tools.git] / tests / tools / streaming / Makefile.am
diff --git a/tests/tools/streaming/Makefile.am b/tests/tools/streaming/Makefile.am
new file mode 100644 (file)
index 0000000..251a378
--- /dev/null
@@ -0,0 +1,18 @@
+AM_CFLAGS = -I. -O2
+AM_LDFLAGS =
+
+if LTTNG_TOOLS_BUILD_WITH_LIBDL
+AM_LDFLAGS += -ldl
+endif
+if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
+AM_LDFLAGS += -lc
+endif
+
+if HAVE_LIBLTTNG_UST_CTL
+noinst_PROGRAMS = gen-ust-events
+gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
+gen_ust_events_LDADD = -llttng-ust
+endif
+
+noinst_SCRIPTS = run
+EXTRA_DIST = run
This page took 0.024862 seconds and 4 git commands to generate.