Tests: Add a health check utility program
[lttng-tools.git] / tests / tools / health / Makefile.am
diff --git a/tests/tools/health/Makefile.am b/tests/tools/health/Makefile.am
new file mode 100644 (file)
index 0000000..09573db
--- /dev/null
@@ -0,0 +1,20 @@
+AM_CFLAGS = -I. -O2 -g -I../../../include
+AM_LDFLAGS =
+
+if LTTNG_TOOLS_BUILD_WITH_LIBDL
+AM_LDFLAGS += -ldl
+endif
+if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
+AM_LDFLAGS += -lc
+endif
+
+UTILS=
+
+noinst_PROGRAMS = health_check
+
+health_check_SOURCES = health_check.c $(UTILS)
+health_check_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+                    $(top_builddir)/src/common/libcommon.la
+
+noinst_SCRIPTS =
+EXTRA_DIST =
This page took 0.023755 seconds and 4 git commands to generate.