Add Log4j 2.x agent tests for the 'log4j' domain
[lttng-tools.git] / tests / regression / ust / java-log4j2 / Makefile.am
diff --git a/tests/regression/ust/java-log4j2/Makefile.am b/tests/regression/ust/java-log4j2/Makefile.am
new file mode 100644 (file)
index 0000000..5489270
--- /dev/null
@@ -0,0 +1,32 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+JAVAROOT = .
+
+noinst_SCRIPTS = \
+       test_agent_log4j2_domain_log4j
+
+EXTRA_DIST = \
+       JTestLTTngLog4j2.java \
+       domain-log4j.xml \
+       test_agent_log4j2_domain_log4j
+
+if TEST_JAVA_LOG4J2_AGENT
+dist_noinst_JAVA = JTestLTTngLog4j2.java
+endif # TEST_JAVA_LOG4J2_AGENT
+
+all-local: static_file
+
+static_file:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       rm -f *.class
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022733 seconds and 4 git commands to generate.