Test: Add the new log4j agent
[lttng-tools.git] / tests / regression / ust / java-log4j / Makefile.am
diff --git a/tests/regression/ust/java-log4j/Makefile.am b/tests/regression/ust/java-log4j/Makefile.am
new file mode 100644 (file)
index 0000000..7035ecf
--- /dev/null
@@ -0,0 +1,34 @@
+if BUILD_JAVA_LOG4J_AGENT
+
+noinst_SCRIPTS = test_java_log4j JTestLTTng.java
+EXTRA_DIST = test_java_log4j JTestLTTng.java
+
+if HAVE_JAVA_JDK
+JCC=$(JAVA_JDK)/bin/javac
+else
+JCC=javac
+endif
+
+all-local: JTestLTTng.class
+
+%.class: %.java
+       $(JCC) -d "$(builddir)" $(JAVACFLAGS) $<
+
+JTestLTTng.class: JTestLTTng.java
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       rm -f *.class
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+endif # BUILD_JAVA_LOG4J_AGENT
This page took 0.023497 seconds and 4 git commands to generate.