Tests: Java agent: update after Java agent refactoring
[lttng-tools.git] / tests / regression / ust / java-log4j / Makefile.am
index 7d6c0481a0997629587a9183299560b5b32972e7..42daab81b85d9d51c908a8c97de759e5950ab6d1 100644 (file)
@@ -1,24 +1,13 @@
+JAVAROOT = .
 
 noinst_SCRIPTS = test_java_log4j JTestLTTng.java
 EXTRA_DIST = test_java_log4j JTestLTTng.java
 
-if HAVE_JAVA_JDK
-JCC=$(JAVA_JDK)/bin/javac
-else
-JCC=javac
-endif
-
-# We still need to copy static files for out of tree and dist build
 if BUILD_JAVA_LOG4J_AGENT
-all-local: static_file JTestLTTng.class
-
-%.class: %.java
-       $(JCC) -d "$(builddir)" $(JAVACFLAGS) $<
-else
-all-local: static_file
+dist_noinst_JAVA = JTestLTTng.java
 endif # BUILD_JAVA_LOG4J_AGENT
 
-JTestLTTng.class: JTestLTTng.java
+all-local: static_file
 
 static_file:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.022701 seconds and 4 git commands to generate.