Tests: Ust getcpu override plugin
[lttng-tools.git] / tests / regression / ust / getcpu-override / Makefile.am
diff --git a/tests/regression/ust/getcpu-override/Makefile.am b/tests/regression/ust/getcpu-override/Makefile.am
new file mode 100644 (file)
index 0000000..f1026ac
--- /dev/null
@@ -0,0 +1,37 @@
+AM_CPPFLAGS = -I$(srcdir)
+
+# The rpath is necessary because libtool won't build a shared library
+# if it's noinst_
+GETCPU_LIBTOOL_FLAGS = \
+    -module \
+    -shared \
+    -avoid-version \
+    --no-as-needed \
+    -rpath $(abs_builddir)
+
+noinst_LTLIBRARIES = lttng-ust-getcpu-override-test.la
+lttng_ust_getcpu_override_test_la_LDFLAGS = $(GETCPU_LIBTOOL_FLAGS)
+
+if LTTNG_TOOLS_BUILD_WITH_LIBDL
+lttng_ust_getcpu_override_test_la_LIBADD = -ldl
+endif
+if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
+lttng_ust_getcpu_override_test_la_LIBADD = -lc
+endif
+
+noinst_SCRIPTS = test_getcpu_override run-getcpu-override
+EXTRA_DIST = test_getcpu_override run-getcpu-override
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023442 seconds and 4 git commands to generate.