Tests: Add "daemon" ust regression test
[lttng-tools.git] / tests / regression / ust / daemon / Makefile.am
diff --git a/tests/regression/ust/daemon/Makefile.am b/tests/regression/ust/daemon/Makefile.am
new file mode 100644 (file)
index 0000000..d457c06
--- /dev/null
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -I$(srcdir)
+
+noinst_PROGRAMS = daemon
+daemon_SOURCES = daemon.c ust_tests_daemon.h
+daemon_LDADD = -llttng-ust -llttng-ust-fork
+
+if LTTNG_TOOLS_BUILD_WITH_LIBDL
+daemon_LDADD += -ldl
+endif
+if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
+daemon_LDADD += -lc
+endif
+
+noinst_SCRIPTS = test_daemon test_daemon.py
+EXTRA_DIST = test_daemon test_daemon.py
This page took 0.023881 seconds and 4 git commands to generate.