Test: add UST baddr statedump test
[lttng-tools.git] / tests / regression / ust / baddr-statedump / Makefile.am
diff --git a/tests/regression/ust/baddr-statedump/Makefile.am b/tests/regression/ust/baddr-statedump/Makefile.am
new file mode 100644 (file)
index 0000000..f45c5ae
--- /dev/null
@@ -0,0 +1,26 @@
+AM_CPPFLAGS = -I$(srcdir) -g
+
+noinst_PROGRAMS = prog
+prog_SOURCES = prog.c tp.c tp.h
+prog_LDADD = -llttng-ust -ldl
+
+noinst_SCRIPTS = test_baddr-statedump test_baddr-statedump.py
+EXTRA_DIST = test_baddr-statedump test_baddr-statedump.py
+
+all-local: prog$(EXEEXT)
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+       objcopy --only-keep-debug prog prog.debug
+       strip -g prog
+       objcopy --add-gnu-debuglink prog.debug prog
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+       rm -f prog.debug
This page took 0.022594 seconds and 4 git commands to generate.