Fix: support VPATH build for tests
[lttng-tools.git] / tests / regression / ust / Makefile.am
index dbc9a17c16e415c69431954eeff7765c53061750..b3620c008f44d4081422ca85a9ac2aa3b35243a6 100644 (file)
@@ -5,4 +5,18 @@ SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
 
 EXTRA_DIST = test_event_basic test_event_wildcard
 
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
 endif
This page took 0.023455 seconds and 4 git commands to generate.